Yuriko.Net 個別記事

2008-07-16
晴れ

複数プラグインの有効化・無効化に未対応

ゆりこ による 15:57:49 の投稿
カテゴリー: WordPressハック
タグ: ,

先日リリースした Ktai Style 1.42 ですが、WordPress 2.6 対応が不十分だったことが分かりました。それは、複数プラグインの有効化・無効化に対応していないという問題です。Ktai Style を有効にしたとき、ログインセッション保存用のテーブルを作成し、無効にしたときテーブルを削除するのですが、複数有効化・無効化を検知していないのです。このため、Ktai Style を1つだけ無効にし、その後、他のプラグインとまとめて有効にしようとすると、携帯電話からログインできなくなってしまいます。

WP_CONTENT_DIR を移設したときの対策も思いつきましたので、それらを含めた 1.43 を WordPress 2.6 日本語版が出てからリリースすることにしましょう。Ktai Style の日本語表示は、WordPress 自体の日本語表示に一部頼っていますので、WordPress 2.6 の日本語リソースの出来具合をみないことには、Ktai Style の日本語リソースを調整できないのです……。

トラックバック・コメント »

  1. いい機会と思ってこちらで最新のktaiStyleをダウンロードしたところ、ログインとコメント投稿ができなくなりました。

    ログイン画面自体がでないんでしょうか? ログイン時に「ログインセッションが生成できませんでした。」というエラーになるんでしょうか。
    前者はあまり考えられないんですが、アップデートに失敗しているのかもしれません。後者の場合は、WordPress 2.5.1 でも「まとめて停止」「まとめて再有効化」すると問題が発生するのが理由かもしれません。Ktai Style だけを表の右側にある「有効にする」リンクで有効化してみてください。

上に戻る

※スパム対策プラグインの影響により、すぐにトラックバックが反映されない場合があります。お手数ですが、半日ほど待ってみてください。

コメント返信

※発言の責任を明確にするため「名無し」「通りすがり」「匿名希望」等の匿名は不可とします。捨てハンドルでもいいので必ず名乗ってください。
XHTML (使えるタグ): <a href="" title="" ktai=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <img localsrc="" alt=""> .
※スパム対策プラグインの影響により、すぐにコメント内容が表示されない場合があります。お手数ですが、半日ほど待ってみてください。

上に戻る