2009年2月18日の投稿

2009-02-18
晴れ

Ktai Style 1.70 は WP 2.5 以降サポート

ゆりこ による 00:46:40 の投稿
カテゴリー: WordPressハック
タグ: , ,

近日リリース予定の Ktai Style 1.70 (バージョン番号は 1.61 をやめて 1.70 になりそう) ですが、サポート対象の WordPress を 2.5 以降とすることにしました。1.60 では、管理機能が WordPress 2.5 以降のみ対応としましたが、1.70 では閲覧機能も 2.5 以降サポートとします。WordPress 2.3.3 以前では、旧安定版である 1.4x 系統をご利用頂きますようお願いします。

なお、1.4x 系統は、逆に、動作対象を 2.3.3 までと短縮します。現状では WordPress 2.5 〜 2.6.5 でも問題なく動作しますが、テストが大変なので、サポート対象から外して、継続した提供をしやすくします。

1.70 の開発版で出た不具合修正を 1.48 にバックポートして動作確認しているとき、閲覧機能については Ktai Style 1.70, 1.48 の両方とも WP 2.0以降での確認が必要と考えて作業していましたが、さすがに煩雑に感じました。1.4x 系統を残すのは、WordPress 2.2, 2.3 で管理機能を使いたい人のためですが、それならば、WordPress 2.2, 2.3 では 1.70 以降をサポートする必然性が少なくなります (管理機能はいらないかわりに新テーマを使いたい人だけのバージョン)。新テーマを使いたい場合は、WordPress 自体を 2.5 以降にアップグレードして頂きますようお願いします。

これにより、古いバージョンをサポートするためのコードを多少削れるため、現在その調整作業をしています。その他、WP Super Cache での設定を簡便にできる機能を 1.70 系に追加するなど、RC1 からの変更も多少あります。乞御期待!!

[追記] バージョン番号は、1.61 ではなく 1.70 にすることにしました。1.61 は、当初1.60 のバグフィックスとして開発しましたが、新テーマを追加すること/サポートする WP バージョンが変更されることから、バージョン番号の変化を大きくした方が分かりやすいだろうと判断したためです。

Ktai Style 1.70 を正式リリースしました。