Yuriko.Net 個別記事

2010-08-01
晴れ

WordPress 3.2 からPHP4サポート廃止

ゆりこ による 2019-12-07 15:52:28 の投稿
カテゴリー: WordPressハック,コンピューター
タグ: , ,

GO PHP 5

7月23日、WordPress 開発者が WordPress 3.2 から PHP4.x および MySQL 4.x のサポートを打ち切り、PHP5.2 以降および MySQL 5.0.11 以降のみのサポートとすることを発表しました。WordPress 3.1 までは 3.0.x と同じく、PHP4.3 以降および MySQL 4.1.2 以降のサポートとなります。

PHP4 をサポートしないプラグインを作っている作者としては非常にうれしいニュースです。Ktai Style や Ktai Entry で PHP4 をサポートしなかったのは、「もはや PHP4 は使うべきではない」という信念に基づいたものでした。2008年8月8日で PHP4 が終了することも発表されてましたし、PHP5 のクラス機構をバリバリ使いたかったし。しかし、2007年の Ktai Style リリース時点ではまだまだ PHP4 の環境も多く、「動きません」という質問も多く苦労しました。2009年後半からは PHP バージョンに関する質問が減り、ユーザーにも PHP5 環境が普及してきたと推測されました。

個人的には、WordPress 3.0 の時点で PHP4 を切ってもらいたかったですが、3.0 の開発時点ではまだまだ PHP4 の環境が残っていたという判断だったのでしょうか? そして、一気に PHP 5.2 以降のサポートとなり、PHP 5.0 と 5.1 は見捨てられました。PHP 5.0 は出来が悪いため仕方ないと思いますが 5.1 は入れてもいい気がします。5.1 → 5.2 における互換性のない変更は非常にマイナーなものばかりですし。

トラックバック・コメント »

コメントはありません。

上に戻る

※スパム対策プラグインの影響により、すぐにトラックバックが反映されない場合があります。お手数ですが、半日ほど待ってみてください。

コメント投稿

※発言の責任を明確にするため「名無し」「通りすがり」「匿名希望」等の匿名は不可とします。捨てハンドルでもいいので必ず名乗ってください。
XHTML (使えるタグ): <a href="" title="" ktai=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <img localsrc="" alt=""> .
※スパム対策プラグインの影響により、すぐにコメント内容が表示されない場合があります。お手数ですが、半日ほど待ってみてください。

上に戻る